Instructions for Installing and Configuring VA Certificates

I. Mandatory Steps

Step 1. Check the required Software Internet Explorer 4.0 (or higher versions) and Outlook 98 (or higher versions)

1.1 Verify the Cipher Strength of Internet Explorer (128-bit)

Check the cipher strength and version number of Internet Explorer:

Double-click on the Internet Explorer icon on your desktop. Click the Help menu item.  Next click on the About Internet Explorer selection.  
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If the Help/About Internet Explorer screen doesn’t show the Cipher Strength to be 128-bits then you will need to upgrade your browser.

Follow the instructions listed in section 2.3 of the Installation and Configuration Guide document available at http://www.va.gov/proj/vapki/forpki.htm to update the Cipher Strength of your browser.

Step 2. Enroll in the VA PKI Program

The VA PKI Program is using the VeriSign OnSite Enterprise software.  As part of the OnSite Enterprise, the Certificate Authority functions are hosted on-site at the VA Silver Spring, Maryland facility. This includes the enrollment process that is described below.

2.1 Obtain a PIN for enrollment from your Local Registration Authority

Local registration authorities at participating facilities are listed at the site at http://www.va.gov/proj/vapki/regauth.htm . They verify applicants’ identity and provide them a shared secret to use for enrollment (the enrollment PIN). If your facility does not have a local registration authority at this time, you or your facility information security officer may contact one of the following:

Suzette Holston

Phone # 785-350-4546

E-mail: Suzette.Holston@med.va.gov
OR

Dan Maloney 

Phone # 301-734-0107

E-mail: Daniel.Maloney@med.va.gov

2.2 Request a VA Certificate

Use the link https://vaww.va.gov/vapki2 to apply for your personal VA Digital Certificate from the Department of Veterans Affairs Certificate Authority after you get an enrollment pin from your Local Registration Authority.

You must select the following features when you are requesting a VA Certificate

1. After filling the enrollment form and clicking of the Submit button the following screen will appear.
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Note: If you have more than one e-mail address, use the most prominent one that is in the standard VA e-mail address format for e.g firstname.lastname@med.va.gov . You can contact your Local Exchange Administrator to find out your correct e-mail address.

2. Confirm your e-mail address and click OK.

3. After you click OK. Do not select OK again.  Select the Set Security Level button to change the security level from medium to high. 
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4. The next step is to provide a common name for your certificate (Digital ID) as well as a password to protect it.  Select the Create a new password for this item and provide a name for the certificate.  This will create a Key Container that will hold your certificate and private key. Next enter a password that protects your private key from unauthorized modifications.

Note: If you have already created a Key Container, you can choose the option “Use this password to access this item”. All your private keys and certificates will be stored in the same Key Container protected with the same password.  

If you get the following error
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Choose another name (an unique name that was not used before) in Password For: field and re-enter the Password and Confirm fields.

Note:  You will not be able to use your Digital ID if you forget this password.  

5. When you have entered the requested information, click Finish to continue.

6. You will be asked for your password twice, once to create your new key and the other for sending a request with your new key.
7. If the enrollment process was successful, you will get an enrollment successful message.  You digital ID will be downloaded and installed on your computer.
Step 3. Configure Your E-mail Client Outlook to use your certificate

From the main menu of Outlook toolbar select the Tools menu and from a list under it select Options then select the Security tab. From the screen displayed, select the Change Settings button in the Secure e-mail area.  The screen displayed should have two Choose buttons. 

· Under Digital Signature, press the “Choose…” button.

Your VA PKI Certificate should be shown in the block.  To select your Certificate highlight it and then press the OK button. 

· Under Encryption, press the “Choose…” button

Your VA PKI Certificate should be shown in the block.  To select your Certificate highlight it and then press the OK button. 

Step 4. Sending and Receiving Secure Email 

Microsoft Outlook uses certificates to support S/MIME email messages that can be digitally signed or encrypted.  S/MIME is an Internet-based protocol that specifies how to digitally sign or encrypt MIME-based messages. MIME is an Internet-based protocol for email. 

4.1 Sending digitally signed e-mail

Your digital signature enables recipients to verify you sent the message and that it was not altered during transmission.  Signing a message does not affect the contents of the message in any way or protect the message from being intercepted and read by someone other than the intended recipient. To ensure that only the intended recipient can read the message, you must also encrypt the message. If a recipient of a signed message does not use an S/MIME-enabled e-mail package, that person can still read the message - your digital signature simply shows up as an attachment. 

[image: image21.png]dbab4036-608:

d3-8412-00400534a8ca

Chosse ofcreate & password to protect s tem.

€ Wse this password to acoess tis tem.

Passwordfor [ o]

& Create a new password for this tem.
Possword o [vASubscrber

(evample: Tom)
Passward:

Confim:

<Back Erish Cancel





The signed icon indicates a message has been signed. You can sign individual messages or configure your e-mail security options to automatically sign all of the e-mail messages you send.

4.1.1 Signing Individual Messages

To sign an outgoing message: 

1. In the New Message window click on the Options... button. Clicking the Options... button will open a window, which allows to you sign and encrypt your message. 
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2. In the window, which appears select whether, you want to sign or sign and encrypt your message. 

Note: If you are sending signed messages outside the VA, it is preferred that you use plain text format for the messages rather that HTML or Rich Text formats. You can find this option under the Format menu as shown in the figure above.
4.1.2 Automatically Signing All Outgoing Messages

To configure Outlook 2000 to sign all messages:

1. Select the Tools menu and scroll to Options.

2. Click the Security tab. 

3. In the window displayed enable the "Add digital signature to outgoing messages" checkbox. 

4.2 Sending encrypted e-mail

To encrypt a message, you need the intended recipient's Certificate. When you receive a signed message, you can store the sender's Certificate in your address book. You can also retrieve correspondents' Certificates from online directories. For more information about storing and maintaining Certificates in your address book, see section 5.4 Managing Correspondents' Certificates of the Installation and Configuration Guide document available at http://www.va.gov/proj/vapki/forpki.htm .
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The Encrypt Message icon indicates a message has been encrypted. You can encrypt individual messages or configure your e-mail security options to automatically encrypt all e-mail messages to recipients whose Certificates are stored in your address book.

4.2.1 Encrypting Individual Messages 

To encrypt an outgoing message: 

1. In the New Message window click on the Options... button. Clicking the Options... button will open a window, which allows to you sign and encrypt your message (see below). 
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2. In the window, which appears, select both the sign and encrypt message options.

4.2.2 Automatically Encrypting Outgoing Messages

To configure Outlook 2000 to encrypt all messages:

1. Select the Tools menu and scroll to Options. 

2. Click the Security tab. 

3. In the window displayed enable the "Encrypt contents and attachments for outgoing messages" checkbox.

4.3 Receiving Encrypted or Signed E-Mail

The signed icon indicates a message has been signed. When you sign a message, this icon is displayed in the lower right corner of the address pane. When you receive a signed message, the signed icon is displayed when you view the message in Outlook. 

When you receive an encrypted or signed message, Outlook automatically decrypts the message and displays the encrypted and/or signed icons as the message is viewed.
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Note the encrypted and signed icons indicating this message was both signed and encrypted upon receipt in Outlook.

4.4 Setting Up Your Toolbar for Secure E-mail

Note: If you are using Microsoft Word as your email editor, you cannot add these buttons.

To make signing and encrypting messages easier, you may also add the Sign and Encrypt icons to your browser's tool bar. When finished, you will be able to sign and encrypt messages with the click of a button.

1. Open a new mail message. 

2. In the message window, go to View, Toolbars, Customize.
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3. Select the "Commands" tab and click on "Standard" under categories.
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4. Scroll down the list under Commands and drag and drop the "Encrypt Message Contents" and "Digitally Sign Message" icons into the toolbar. (Note: Drop the icons anywhere to the left of the office assistant icon).
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5. Click the "Close" button. Once complete, your toolbar will contain both the sign and encrypt icons.
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Step 5. Save your Digital ID to a File

Saving your Digital ID to a diskette is very important.  If the Digital ID stored on your PC workstation was to become corrupted or accidentally deleted, you can restore your Digital ID.  Save your Digital ID in a secure location outside of your workstation.  By saving your Digital ID to a diskette you can restore a deleted or corrupted Digital ID.  If you change workstations or move to a laptop, you will be able to install your Digital ID and use it on that system.

Select the Internet Explorer icon on the workstation’s desktop.  From the main menu toolbar select the Tools menu.  From the Tools menu select the Internet Options choice.

Select the Content tab.  Once the Content tab is selected, click on the Certificates button.

Select your VA PKI certificate (You will find two certificates one is for signing and the other one is for encryption. You need to repeat the same process for the second certificate.) by highlighting the element. Next click on the Export button.  The screen below will appear.  The export process requires a password to protect the certificate. At the Filename prompt, you may enter a path name as well as the file name.  (for example:  a:\DigitalID)

1. Click on the Next button.

2. In the next window displayed, choose the option “Yes, export private key” and click on Next button.

3. In the next window displayed, select Personal Information Exchange – PKCS #12 (.PFX) format, also choose “Enable strong protection” and “Include all certificates in the certification path if possible” options.

4. In the next window displayed, enter the password you have used to protect the file, where the keys are exported.

5. In the next window displayed, at the Filename prompt, you may enter a path name as well as the file name.  (for example:  a:\DigitalID). You can also choose the Browse button to select the path name.

6. In the next window displayed, click on the Finish button.

7. You will need to enter the password you have used to protect your private key and click on the OK button.  

8. If the export is successful a message box saying “The export was successful” will be displayed. 

Step 6. Enable CRL Checking for Outlook

A Certificate Revocation List (CRL) is a file maintained and published by a Certification Authority (CA) that lists certificates issued by the CA that are revoked. The CRL contains the serial numbers of public-key certificates (digital IDs) that are revoked. CRLs are placed in directories so that applications and users can check the revocation status of certificates before trusting them. 

Outlook does not currently download the Certificate Revocation List (CRL) without some modifications to the registry. 

You should contact your SYSTEM ADMINISTRATOR to add the following registry keys.

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. We cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
1. Start the Registry Editor (Start ->Run and type in regedit.exe and click on OK button)
2. Locate the following subkey in the registry:
HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0\Outlook
3. On the Edit menu, click New, and then click Key.

4. Type Security to name the new subkey, and then select this new subkey.

5. On the Edit menu, click Add Value, and then add the following registry value:

Value Name: UseCRLChasing
Data Type: DWORD (Hexadecimal)
Value: 1 
6. Locate the following subkey in the registry:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography
7. On the Edit menu, click New, and then click Key.

8. Type {7801ebd0-cf4b-11d0-851f-0060979387ea} to name the new subkey, and then select this new subkey.

9. On the Edit menu, click Add Value, and then add the following registry value:

Value Name: PolicyFlags
Data Type: DWORD (Hexadecimal)
Value: 10000 

10. Close out Outlook and open it again for these changes to take effect.

Verify CRL was downloaded

To verify that the CRL was downloaded, open Internet Explorer and perform the following steps:

1. In the Internet Explorer menu, select Tools -> Internet Options

2. Click the General tab

3. Click Settings. This will present you with another dialog box.

4. Select View Files and the Temporary Internet Files folder will be displayed.

5. You can search for the file LatestCRL.crl to verify that it was downloaded.

Configuring Outlook to Suppress Name Checking

In S/MIME version2, certificates for email are required to have the correct email address in the certificate. In S/MIME version 3, the email address is not required to be in the certificate. Outlook 2000 can be configured to conform to S/MIME version 3 and use any valid certificate for email. To configure Outlook to conform to S/MIME version 3, you need to add the following registry key:

1. Locate the following subkey in the registry:
HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0\Outlook 

(If the subkey Security is present select it and go to step 4 otherwise add the subkey by following instructions in steps 2 and 3)

2. On the Edit menu, click New, and then click Key.

3. Type Security to name the new subkey, and then select this new subkey.

4. On the Edit menu, click Add Value, and then add the following registry value:

Value Name: SupressNameChecks
Data Type: DWORD (Hexadecimal)
Value: 1
Close out Outlook and open it again for these changes to take effect.
II. Optional Configurations

1. Setting up Your Contacts File For Message Encryption

Now that you have your Digital ID, it is simple to configure your Outlook 2000 email program to use it.  By using your Digital ID and those of other trusted folks, you can send and receive digitally signed and encrypted emails. This step is necessary to send encrypted emails to others because you need their public-key certificate to encrypt the email. 

The first step is to configure Outlook 2000 to use the Contacts database.  The Contacts database stores the Digital IDs of other users.  We suggest that you configure Outlook 2000 to use the Contacts file first rather than your Global Address book.   If this proves inconvenient because you use the Global Address book heavily for mail to those who do not have digital IDs, you may find it necessary to return the Global Address List back to first position.

Select the Microsoft Outlook icon from your workstation’s desktop.  From the menu, select Tools and then Services…
Under the Services tab, verify that Outlook Address Book is listed.  If it is listed then select the Cancel button.  If not, simply use the Add button feature to add it. 

Next, select the Addressing tab.

Under the Show this address list first section, select the Contacts option. 
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Next, under the When sending mail, check names using these address lists in the following order section, confirm that the Contacts entry is first.  If not, use the up-arrow key next to the display box to move Contacts to the first entry position. The Global Address List should follow next. Click OK and return to the primary outlook screen.

2.   Restoring the Digital ID from the file

If the Digital ID stored on your PC workstation was to become corrupted, accidentally deleted, change workstations or move to a laptop, you will need to restore your Digital ID and use it on that system.

1. Select the Internet Explorer icon on the workstation’s desktop.  From the main menu toolbar select the Tools menu.  From the Tools menu select the Internet Options choice.

2. Select the Content tab.  Once the Content tab is selected, click on the Certificates button.

3. Next click on the Import button. 

4. In the next window displayed, select the file in which your keys were exported and click on Next.

5. In the next window displayed, enter the password used during the export process to access the file and select both the options “Enable strong private key protection” and “ Mark the private key as exportable”.

6. In the next window displayed, select the option “Automatically select the certificate store based on type of certificate” and click on Next button.

7. In the next window displayed, click on the Finish button. The following screen will be displayed next.  Click on the Set Security Level button. 
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8. Set the security level to high and click on the Next button.
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9. In the next window displayed, select the option “Create a new password for this item” and type in your name in the field “Password for:” Select a password to access you private key and click on Finish button. 

10.  In the next window displayed, enter the same password (as the previous step) and click on OK button.

11. If the import process is successful a message box saying, “The import was successful” will be displayed. 

3. Changing password

You can change the password for your certificate by exporting your certificate and importing it back.  During the import process you can change the password the certificate.

For more information about saving and restoring Digital IDs, see section 4 Saving and Restoring your Digital ID of the Installation and Configuration Guide document available at http://www.va.gov/proj/vapki/forpki.htm .
4. Revoking your certificates

If there is a problem with your current certificate you can revoke it by following the steps listed below.

· Click on the URL below to start the process: https://vaww.va.gov/vapki2
· Click on “Revoke”

· Enter your e-mail address and click on “Search”.

· Click on the certificate you want to revoke.

· Click on the “Revoke” button

· Enter the challenge phrase; select a reason for revocation and click on “Revoke”.

Note: In order to revoke your certificate you need the challenge phrase you put in during enrollment. If you do not remember your challenge phrase please contact the VA PKI Helpdesk.

If the revocation is successful a success message will be displayed. 

5. Configuring Outlook 2000 to use the VA LDAP directory for sending encrypted e-mail

You can configure your Outlook 2000 client to use the VA LDAP directory for sending encrypted e-mails to other users. By using this directory you need not have certificates stored in your Contact list. 

Some Important Facts Before Getting Started

· You need to install Outlook 2000 Service Pack 1 and Service Pack 2.  Installing these Service Packs is a complicated process, you will be asked for the Office 2000 installation CD.  You will have to reboot your machine several times during this installation. It is recommended that this process be done by the Local System Administrator

· You need the high encryption patch (cipher strength 128 bits) for Outlook. This is not the same as the high encryption pack for Internet Explorer. You can find out the cipher strength of Outlook by clicking Help/About Microsoft Outlook, you will get About Microsoft Outlook window. Click on the Security Info button.  The following window will be displayed. Check to see if the Cipher Strength is 128 bits.
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You can download the service packs and the high encryption pack by using the “Office on the Web” feature of Outlook 2000.

Select “Office on the Web” feature under the Help menu

Click on “Product Updates” from the web page.

Select the following updates and click on “Start Installation”

Office 2000 Service Release 1a (SR-1a)

Office 2000 Service Pack 2 (SP-2)

Updated 128-Bit Encryption Provider for Outlook 2000

Setting Up the VA LDAP Service.

To add the Corporate LDAP service to a profile, follow these steps: 

1. Start Outlook if it is not currently running. 

2. On the Tools menu, click Services. 

3. Click Add, select Microsoft LDAP Directory, and then click OK. 

4. Type the following information for the Directory service you will be using.

Directory Service Account: 
VA LDAP Directory

Server Hostname:


vaww.certs.va.gov

Server Port Number:

389

Use Secure Socket Layer:

(UNCHECKED)

Server Timeout:


60

User Name:




Password:




Search Base:


o=va.gov
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Sending Encrypted e-mail using VA LDAP server

1. Open a New mail message by clicking on the New button.

2. Click on the To button.

3. From the right hand side under the Global Address List, 

select LDAP – vaww.certs.va.gov
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4. Next, click on the Find button.

5. Enter the recipients name and click OK.
6. If the search is successful, the name will be displayed, select the name displayed as a recipient of the e-mail.

7. Select the Encryption button on the new e-mail and send it after typing your e-mail.
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