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I
Introduction

This Installation and Configuration Guide for Secure Email and Secure Web has been created to support the VA Public Key Infrastructure (PKI) Program.  The PKI Program participants include VA employees and non-VA employees.  The VA possesses a site license for some Microsoft products including Internet Explorer and Outlook.  This guide is a living document and will be updated to meet participant’s needs.  Initially, the guide considers Internet Explorer 5.0 and Outlook 2000.  It is recognized that some non-VA participants will use other client software. Future releases of this guide will provide information on these products.

1
Some Important Facts Before Getting Started

· You need the latest software email program that will support S/MIME.

· You need the Microsoft Enhanced Cryptographic Provider or the strong encryption patch.  

· When enrolling for your certificate make sure you select the following: 

Select the high level of security for your certificate. This will protect your private key with a password.  This will prevent others from using it.

· Before you begin, prepare a word or phrase that will be used as a challenge in the future if you need to revoke or replace your digital ID.  You will also need a new password that will be required whenever you encrypt, decrypt, or digitally sign a message.

After enrolling, remember the password and the challenge word or phrase that you selected.

· Once you have obtained your certificate (Digital ID) you will then need to export it to a file.  That way if you have to replace your PC or do other major reconfigurations, you will be able to reinstall your certificate.

· If you send a digitally signed message to someone who does not have an e-mail client that supports S/MIME, then they will not be able to read the message other then your name and the subject line.  In the VA, that means that only people who have installed the Outlook 2000 e-mail client can read digitally signed messages.

II
Mandatory Steps

Step 1.
Software Installation Instructions

1
Installing Internet Explorer 

The VA PKI is using the Microsoft Internet Explorer version 5.0. If you do not have at least version 5.0, click on the URL below:

http://www.microsoft.com/windows/ie/download 

Then click at the bottom of the screen on the Other Options button.
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The following screen will be displayed next.

The Microsoft web site will automatically detect your operating system and will display the appropriate options.  Select the Internet Explorer 5.01 and Internet Tools.
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Follow the instructions to complete the upgrade. It will be necessary to reboot your computer. 

2
Verifying the proper Cipher Strength for Internet Explorer

Check the cipher strength and version number of Internet Explorer:

Double-click on the Internet Explorer icon on your desktop. Click the Help menu item.  Next click on the About Internet Explorer selection.  It should look something like this: 
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If the About / Internet Explorer screen doesn’t show the Cipher Strength to be 128-bits then you will need to upgrade your browser.  See the next step. 

3
Upgrading to the 128-bit Internet Explorer

If your Internet Explorer browser has cipher strength of 128-bits, then continue to the next step.

The Microsoft site that contains the 128-bit cipher strength version of Internet Explorer is located here: 

http://www.microsoft.com/windows/ie/download/128bit/intro.htm
Follow the instructions on the Microsoft web site. 
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4
Outlook 2000 Software

Unlike Internet Explorer and Outlook Express software that is free and downloadable, the Outlook 2000-email software must be obtained from your local network administrator.  Please contact him or her and not the VA PKI help line to get this installed.

Note:  You do not need Outlook 2000 installed to do secure Web transmissions.  

Step 2.
Enrolling in the VA PKI Program

1
Acquisition and Configuration of Your Digital ID 

The VA PKI Program is using the VeriSign OnSite Enterprise software.  As part of the OnSite Enterprise, the Certificate Authority functions are hosted on-site at the VA Silver Spring, Maryland facility. This includes the enrollment process that is described below. 

This guide has been designed to include the various screens that will be displayed throughout this process.  Additional information is provided to help guide you through the enrollment process. 

Click on the URL below to start the process: 

https://vaww.va.gov/vapki2
A screen like this should appear:
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Under the Enroll section select

for Encryption and Signing Digital ID.  

The following three images contain the VA PKI enrollment form.   
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Step1:   Information for the Digital ID
Please enter your full name in the proper spaces.  For an email address, enter your pre-assigned VA e-mail address, (for example, joe.user@med.va.gov).  Enter the enrollment PIN given to you.  If you have not been assigned a PIN or do not remember your PIN please contact the PKI help line.  

WARNING:  All the fields in Step 1 are required.  If they are not completed, the enrollment form will be rejected.

Note: If you have more than one e-mail address, use the most prominent one that is in the standard VA e-mail address format for e.g firstname.lastname@med.va.gov . You can contact your Local Exchange Administrator to find out your correct e-mail address.
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Step 2:  Challenge Phrase 

Please enter a Challenge Phrase that you can easily remember but is not obvious about you (such as a nickname).  

Step 3:  Digital ID Subscriber Agreement

Please read the Agreement.  After reading the Agreement, click the Submit button to continue.

After clicking the Submit button the following screen appears.  
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Confirm your e-mail address and click OK.

You will get the following warning message. Click “Yes”.
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If there are no data entry errors the following screen appears. Do not select OK.  Select the Set Security Level button to change the security level from medium to high. 
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Once the Set Security Level button has been selected, the following screen will appear.  Notice that the current security setting level is Medium.  Using the mouse, select the High option as seen on the next page.
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Before selecting the Next button to continue, please verify that the High button is selected.  With this configuration whenever there is a request to use your private key the password must be entered.  If they do not know your password, then they cannot use your keys.  This is what you want because it protects the use of your private key.  If you leave the default medium security level, you are not prompted for a password when using your private keys.  Therefore, anyone who gains access to your workstation may use your private key to digitally sign electronic mail messages or perhaps contracts. 
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PLEASE VERIFY THAT THE HIGH SECURITY LEVEL IS SET THEN PRESS Next TO CONTINUE.  
The next step is to provide a common name for your certificate (Digital ID) as well as a password to protect it.  Select the Create a new password for this item and provide a name for the certificate.  For example, replace VASubscriber with your name (i.e. John Doe).  Next enter a password that protects your private key from unauthorized modifications. This will create a Key Container that will hold your certificate and private key. 

Note: If you have already created a Key Container, you can choose the option “Use this password to access this item”. All your private keys and certificates will be stored in the same Key Container protected with the same password.  
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Note:  You will not be able to use your Digital ID if you forget this password.  If you forget your password it cannot be recovered and you will have to be assigned a new Digital ID.  If necessary, you may want to record your password in a secure off-site location, such as your house.

If you get the following error
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Choose another name (an unique name that was not used before) in Password For: field and re-enter the Password and Confirm fields.

[image: image103.wmf]When you have entered the requested information, click Finish to continue.  The following screen will appear.  Select OK to continue with the enrollment process.

The following screen will appear. DO NOT DISTURB THE BROWSER UNTIL THE PROCESS IS COMPLETE.
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You will get the following warning message. Click “Yes”.
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If the process is successful, the following screen will be displayed.  If you get any errors, please check if you input your e-mail address and enrollment PIN correctly.  You can also contact the VA PKI helpdesk.
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2
Configuring your Browser to Utilize Your Digital ID

This section includes instructions for configuring the browser to utilize your Digital ID.  Currently, instructions for Internet Explorer are provided.  Instructions for using the Netscape browser will be included later.  If you are not using Internet Explorer, please contact the PKI help line for assistance. 

2.1 Internet Explorer 5 

Select the Internet Explorer icon on your workstation’s desktop.  Once Internet Explorer is active, select the Tools menu from the toolbar.  Then select the last option, Internet Options to configure the browser to use your Digital ID.

Then select the Content tab and click on Certificates button.  
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Validate that your VA PKI Certificate (Digital ID) has been installed in the browser.  Select your VA PKI Certificate by highlighting it and then click on the View  button.  Your VA PKI Certificate should look like this: 
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If you cannot locate your VA PKI Certificate, then please contact the VA PKI help line for assistance. 

3 Enabling your S/MIME Client to Use Your Digital ID

3.1 Configuring Outlook 2000 to Utilize Your Digital ID

Outlook 2000 will not automatically use S/MIME features that permit you to sign and encrypt your email.  The S/MIME features must be manually configured including the selection of a certificate (Digital ID).

Select the Outlook 2000-email icon on the workstation’s desktop.    From the main menu toolbar select the Tools menu.

Next, from the Tools menu select the Options…item as shown below.
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Then select the Security tab.  The process continues on the next page.
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From this screen, select the Change Settings button in the Secure e-mail area.

The process continues on the next page.
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· Next to the Secure Settings Name confirm that the My S/MIME Settings is selected. 

· Under Options/Secure Message Format confirm the S/MIME setting is selected.

· Under Digital Signature, press the “Choose…” button.

Your VA PKI Digital ID should be shown in the block.  To select your Digital ID highlight it and then press the OK button. 

· Under Encryption, press the “Choose…” button

Your Digital Certificate should be shown in the block.  To select your Digital ID highlight it and then press the OK button. 

By clicking on View Certificate you can view your certificate. 
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Click on the Details tab and the following screen will be displayed
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If your certificate does not indicate Public Key (in the Field column) with the value RSA (1024 bits), then please contact the PKI help line for assistance. 

Step 3.
Saving Your Digital ID to a File

Saving your Digital ID to a diskette is very important.  If the Digital ID stored on your PC workstation was to become corrupted or accidentally deleted, you can restore your Digital ID.  If you are not able to restore your Digital ID, then you will need to reapply for a new one.  Saving your Digital ID in a secure location outside of your workstation is recommended. 

By saving your Digital ID to a diskette you can restore a deleted or corrupted Digital ID.  If you do save your Digital ID and it expires, you may not be able to decrypt encrypted messages sent to you.  If you change workstations or move to a laptop, you will be able to install your Digital ID and use it on that system.

1 Saving Your Digital ID From Internet Explorer

Select the Internet Explorer icon on the workstation’s desktop.  From the main menu toolbar select the Tools menu.  From the Tools menu select the Internet Options choice.

Select the Content tab.  Once the Content tab is selected, click on the Certificates button.
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Select your VA PKI certificate by highlighting the element. Next click on the Export button.  The screen below will appear.  The export process requires a password to protect the certificate. At the Filename prompt, you may enter a path name as well as the file name.  (for example:  a:\DigitalID)

Note:  It is recommended that you copy the Digital ID to a diskette and store the diskette in a secure location. 
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Click on the Next button and the following screen will appear.

[image: image24.png][

icate Manager Export Wizard

Export Private Key with Certificate
Indicate ifyou wantto exportthe private key with your certiicate

Private keys requite protection. fyou wantto exportthe private key for the selected cericate,
you will be reguired to enter & password on the following page

Doyou wantto exportthe private key with the certficate?
@ iYes, exportthe private keyl

€ N danot export the private key

<Back Next> Cancel





Choose the option “Yes, export private key” and click on Next button.
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Select Personal Information Exchange – PKCS #12 (.PFX) format, and also choose “Enable strong protection” and “Include all certificates in the certification path if possible” options.
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Enter the password you have used to protect you private key.
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At the Filename prompt, you may enter a path name as well as the file name.  (for example:  a:\DigitalID). You can also choose the Browse button to select the path name.
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Click on the Finish button. The following screen will be displayed next.
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Enter the password you have used to protect your private key and click on the OK button.  A message will be displayed saying that the Export was completed successfully.
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Step 4.
Sending and Receiving Secure Email 

Microsoft Outlook 2000 uses certificates to support S/MIME email messages that can be digitally signed or encrypted.  S/MIME is an Internet-based protocol that specifies how to digitally sign or encrypt MIME-based messages. MIME is an Internet-based protocol for email. 

Microsoft Outlook 2000 also supports digital signature validation and the ability to decrypt encrypted messages sent to you.  The encrypt security service requires the email recipient’s certificate.  Outlook 2000 retrieves this certificate either through its own Contact list or through the Exchange Server if Outlook 2000 is operating as an Exchange client. 

The following instructions have been adapted from the VeriSign web site http://www.verisign.com/client/guide/outlook98.htm
1
Digitally Signing Your E-Mail with Outlook 2000 

The first step to securing your e-mail messages is to sign them using your Digital ID. Your digital signature enables recipients to verify you sent the message and that it was not altered during transmission. With Microsoft Outlook 2000 you can easily sign your outgoing e-mail messages. 

Signing a message does not affect the contents of the message in any way or protect the message from being intercepted and read by someone other than the intended recipient. To ensure that only the intended recipient can read the message, you must also encrypt the message. If a recipient of a signed message does not use an S/MIME-enabled e-mail package, that person can still read the message - your digital signature simply shows up as an attachment. 

	[image: image31.png]





The signed icon indicates a message has been signed. You can sign individual messages or configure your e-mail security options to automatically sign all of the e-mail messages you send.
1.1 Signing Individual Messages

To sign an outgoing message: 

1. In the New Message window click on the Options... button. Clicking the Options... button will open a window, which allows to you sign and encrypt your message. 
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2. In the window, which appears select whether, you want to sign or sign and encrypt your message.
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Note: If you are sending signed messages outside the VA, it is preferred that you use plain text format for the messages rather that HTML or Rich Text formats. You can find this option under the Format menu as shown in the figure below.
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1.2 Automatically Signing All Outgoing Messages

To configure Outlook 2000 to sign all messages:

1. Select the Tools menu and scroll to Options. 
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2. Click the Security tab. 

3. Enable the "Add digital signature to outgoing messages" checkbox. 
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2 Encrypting your E-mail with Outlook 2000

The second step to securing your e-mail is to encrypt the messages you send. Encrypting messages with Outlook 2000 is as easy as signing them. 

To encrypt a message, you need the intended recipient's Digital ID. When you receive a signed message, you can store the sender's Digital ID in your address book. You can also retrieve correspondents' Digital IDs from online directories. For more information about storing and maintaining Digital IDs in your address book, see Managing Correspondents' Digital IDs (LINK).
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The Encrypt Message icon indicates a message has been encrypted. You can encrypt individual messages or configure your e-mail security options to automatically encrypt all e-mail messages to recipients whose Digital IDs are stored in your address book.

2.1 Encrypting Individual Messages 

To encrypt an outgoing message: 

1. In the New Message window click on the Options... button. Clicking the Options... button will open a window, which allows to you sign and encrypt your message (see below). 
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2. In the window, which appears, select both the sign and encrypt message options. 
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2.2
Automatically Encrypting Outgoing Messages

To configure Outlook 2000 to encrypt all messages:

1. Select the Tools menu and scroll to Options. 
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3. Click the Security tab. 

4. Enable the "Encrypt contents and attachments for outgoing messages" checkbox. 
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3 Receiving Encrypted or Signed E-Mail

The signed icon indicates a message has been signed. When you sign a message, this icon is displayed in the lower right corner of the address pane. When you receive a signed message, the signed icon is displayed when you view the message in Outlook 2000. 

When you receive an encrypted or signed message, Outlook 2000 automatically decrypts the message and displays the encrypted and/or signed icons as the message is viewed.
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Note the encrypted and signed icons indicating this message was both signed and encrypted upon receipt in Outlook 2000.

4 Managing Contact’s Digital IDs with Outlook 2000

To send an encrypted message, you must have the recipient's Digital ID in your address book. Outlook 2000 enables you to view Digital IDs stored in your address book as well as easily add and remove contacts' Digital IDs.

4.1 Storing a Digital ID from a Signed Message 

Follow these instructions to add another person's Digital ID to your address book. Once a Digital ID is stored in your address book, you can use it to send that person encrypted messages.

1. Open the signed message from Outlook 2000.
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2. Right mouse-click on the Sender's name in the address field.
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3. Select "Add to Contacts". 

4. If the Sender is not yet in your Contacts address book, a Contact window will appear. Enter any information you want to include, then click on the "Save and close" button. This automatically adds the Sender's Digital ID to your Contact address book.
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5. If the Sender is already in your Contacts address book, you will get another dialog box where "Update this Contact" is selected. Click on OK, which will then bring up the Contact window. Just click on "Save and close", and this will add your contact's Digital ID to your address book.
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5 Downloading and Importing a Digital ID

You can also search VeriSign's public directory for someone's Digital ID, download the ID,and import it to your address book. To search for someone's Digital ID in VeriSign's public directory: 

1. Visit http://www.va.gov/proj/vapki/forpki.htm and follow the instructions to search for, select, and download a Digital ID. 

2. When asked to choose the format for downloading select "Someone else's Digital ID for Microsoft IE (4.0 or later) /Outlook Express/Outlook '98". 

3. Click on the Download button and save the certificate to a file on your computer.

6 To import a downloaded Digital ID into your address book: 

1. Open "Contacts" from Outlook 2000 (Click on the Contacts icon). 

2. If this is an existing contact, double click on your contact's name from the existing list. If this is a new contact, select New, then Contact from the File menu in your toolbar and enter your contact information in the Contact window. 

3. Select the Certificates tab in the Contact window. 

4. Click on the "Import" button. 

5. Locate the Digital ID you just downloaded and click the Open button. 

6. Click on "Save and close".

7 Setting Up Your Toolbar for Secure E-mail

To make signing and encrypting messages easier, you may also add the Sign and Encrypt icons to your browser's tool bar. When finished, you will be able to sign and encrypt messages with the click of a button.

Note: If you are using Microsoft Word as your email editor, you cannot add these buttons.

1. Open a new mail message. 
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2. In the message window, go to View, Toolbars, Customize.
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3. Select the "Commands" tab and click on "Standard" under categories.
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4. Scroll down the list under Commands and drag and drop the "Encrypt Message Contents" and "Digitally Sign Message" icons into the toolbar. (Note: Drop the icons anywhere to the left of the office assistant icon).
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5. Click the "Close" button. Once complete, your toolbar will contain both the sign and encrypt icons.
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Step 5. Enabling Certificate Revocation List (CRL) checking

A Certificate Revocation List (CRL) is a file maintained and published by a Certification Authority (CA) that lists certificates issued by the CA that are revoked. The CRL contains the serial numbers of public-key certificates (digital IDs) that are revoked. CRLs are placed in directories so that applications and users can check the revocation status of certificates before trusting them. 

Outlook does not currently download the Certificate Revocation List (CRL) without some modifications to the registry. 

You should contact your SYSTEM ADMINISTRATOR to add the following registry keys.

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. We cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
1. Start the Registry Editor (Start ->Run and type in regedit.exe and click on OK button)

2. Locate the following subkey in the registry:

HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0\Outlook
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3. On the Edit menu, click New, and then click Key.

4. Type Security to name the new subkey, and then select this new subkey.

5. On the Edit menu, click Add Value, and then add the following registry value:

Value Name: UseCRLChasing

Data Type: DWORD (Hexadecimal)

Value: 1 
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6. Locate the following subkey in the registry:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography

7. On the Edit menu, click New, and then click Key.

8. Type {7801ebd0-cf4b-11d0-851f-0060979387ea} to name the new subkey, and then select this new subkey.

9. On the Edit menu, click Add Value, and then add the following registry value:

Value Name: PolicyFlags
Data Type: DWORD (Hexadecimal)

Value: 10000 

10. Close out Outlook and open it again for these changes to take effect.

[image: image56.png]r

Registry E
Begistry Edit View Fevorites Help

=01 Cryptography =1 [Name Type
% (1 Calais (Default) REG_SZ
% 1 Defaults PolicyFlags REG_DWORD
(1 IEDirtyFlags
10D
% 1 Protect
% 1 Providers
L1 RNG
(1 Senvices
3 {7801ehel0-cf4b-1100-851-0080972387 62}
1 dasetup
%] DataAccess
% 1 DateFactory

|

My ComputerHKEY_LOCAL_MACHINE\SOFTWAREMicrosoftiCryptography (7801 ebd0-cf4b-11d0-551-0060879387 2a}

Data.

(value not set)
0x00010000 (65536)





Note: If you are using Windows 2000 and have not installed Service Pack 3 then you must apply hotfix Q308707, which is currently available from Microsoft Support. Just go to http://support.microsoft.com, click on the search link and use the “Q number shortcut” feature to search on Q308707.

Verify CRL was downloaded

To verify that the CRL was downloaded, open Internet Explorer and perform the following steps:

1. In the Internet Explorer menu, select Tools -> Internet Options

2. Click the General tab

3. Click Settings. This will present you with another dialog box.

4. Select View Files and the Temporary Internet Files folder will be displayed.

5. You can search for the file LatestCRL.crl to verify that it was downloaded.

Configuring Outlook to Suppress Name Checking

In S/MIME version2, certificates for email are required to have the correct email address in the certificate. In S/MIME version 3, the email address is not required to be in the certificate. Outlook 2000 can be configured to conform to S/MIME version 3 and use any valid certificate for email. To configure Outlook to conform to S/MIME version 3, you need to add the following registry key:

1. Locate the following subkey in the registry:

HKEY_LOCAL_MACHINE\Software\Microsoft\Office\9.0\Outlook 

(If the subkey Security is present select it and go to step 4 otherwise add the subkey by following instructions in steps 2 and 3)

2. On the Edit menu, click New, and then click Key.

3. Type Security to name the new subkey, and then select this new subkey.

4. On the Edit menu, click Add Value, and then add the following registry value:

Value Name: SupressNameChecks

Data Type: DWORD (Hexadecimal)

Value: 1

Close out Outlook and open it again for these changes to take effect.
III
Optional Configurations

1
Setting up Your Contacts File For Message Encryption

Now that you have your Digital ID, it is simple to configure your Outlook 2000 email program to use it.  By using your Digital ID and those of other trusted folks, you can send and receive digitally signed and encrypted emails. This step is necessary to send encrypted emails to others because you need their public-key certificate to encrypt the email. 

The first step is to configure Outlook 2000 to use the Contacts database.  The Contacts database stores the Digital IDs of other users.  We suggest that you configure Outlook 2000 to use the Contacts file first rather than your Global Address book.   If this proves inconvenient because you use the Global Address book heavily for mail to those who do not have digital IDs, you may find it necessary to return the Global Address List back to first position.

Select the Microsoft Outlook icon from your workstation’s desktop.  From the menu, select Tools and then Services…
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Under the Services tab, verify that Outlook Address Book is listed.  If it is listed then select the Cancel button.  If not, simply use the Add button feature to add it. 

Next, select the Addressing tab.  The process continues on the next page.

Under the Show this address list first section, select the Contacts option. 
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Next, under the When sending mail, check names using these address lists in the following order section, confirm that the Contacts entry is first.  If not, use the up-arrow key next to the display box to move Contacts to the first entry position. The Global Address List should follow next. Click OK and return to the primary outlook screen.

2
Restoring Your Digital ID From Internet Explorer

Select the Internet Explorer icon on the workstation’s desktop.  From the main menu toolbar select the Tools menu.  From the Tools menu select the Internet Options choice.

Select the Content tab.  Once the Content tab is selected, click on the Certificates button.
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Next click on the Import button.  The screen below will appear.  The import process requires the same password you have used during the export process. 
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Click on the Next button.
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Select the file in which your keys were exported and click on Next.
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Enter the password used during the export process to access the file and select both the options “Enable strong private key protection” and “ Mark the private key as exportable”.
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Select the option “Automatically select the certificate store based on type of certificate” and click on Next button.  The screen below will be displayed.
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Click on the Finish button. The following screen will be displayed next.
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Click on the Set Security Level button. The following screen will be displayed next.
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Select High option and click on Next button. The screen below will be displayed.
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Select the option “Create a new password for this item” and type in your name in the field “Password for:” Select a password to access you private key and click on Finish button. The screen below will be displayed. 
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Enter the password again and click on OK button. The screen below will be displayed. 
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A message saying, “The import was successful” will be displayed.  Click on OK button.  

3
Changing Passwords

You can change the password for your certificate by exporting your certificate and importing it back.  During the import process you can change the password the certificate.

4 Revoking your certificates

If there is a problem with your current certificate you can revoke it by following the steps listed below.

Click on the URL below to start the process: 

https://vaww.va.gov/vapki2
A screen like this should appear:
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Click on “Revoke” and the following screen will appear.
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Enter your e-mail address and click on “Search”. The following search results page will be displayed.
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Click on the certificate you want to revoke and the following screen will be displayed.
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Click on the “Revoke” button and the following screen will be displayed.
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Enter the challenge phrase; select a reason for revocation and click on “Revoke”.

Note: In order to revoke your certificate you need the challenge phrase you put in during enrollment. If you do not remember your challenge phrase please contact the VA PKI Helpdesk.

If the revocation is successful the following success message will be displayed. 
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5
Configuring Outlook 2000 to use the VA LDAP directory for sending encrypted e-mail

You can configure your Outlook 2000 client to use the VA LDAP directory for sending encrypted e-mails to other users. By using this directory you need not have certificates stored in your Contact list. 

Some Important Facts Before Getting Started

· You need to install Outlook 2000 Service Pack 1 and Service Pack 2.  Installing these Service Packs is a complicated process, you will be asked for the Office 2000 installation CD.  You will have to reboot your machine several times during this installation. It is recommended that this process be done by the Local System Administrator

· You need the high encryption patch (cipher strength 128 bits) for Outlook. This is not the same as the high encryption pack for Internet Explorer. You can find out the cipher strength of Outlook by clicking Help/About Microsoft Outlook, you will get About Microsoft Outlook window. Click on the Security Info button.  The following window will be displayed. Check to see if the Cipher Strength is 128 bits.
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You can download the service packs and the high encryption pack by using the “Office on the Web” feature of Outlook 2000.

Select “Office on the Web” feature under the Help menu
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Once this is selected, the following web page will be displayed.
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Click on “Product Updates” from the web page (highlighted in red).  The following web page will be displayed next.
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Once this is complete, the following web page will be displayed.
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Select the following updates and click on “Start Installation”

Office 2000 Service Release 1a (SR-1a)

Office 2000 Service Pack 2 (SP-2)

Updated 128-Bit Encryption Provider for Outlook 2000

Setting Up the VA LDAP Service.

From the Outlook main menu toolbar select the Tools menu.

Next, from the Tools menu select the Services item as shown below.
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The following screen will be displayed next.

Click on the Add button.
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The following screen will be displayed.  Select Microsoft LDAP Directory and click OK.
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The following screen will be displayed next.

Fill in the fields as shown below:

Directory Service Account: 
VA LDAP Directory

Server Hostname:

vaww.certs.va.gov

Server Port Number:

389

Use Secure Socket Layer:
(UNCHECKED)

Server Timeout:

60

User Name:




Password:




Search Base:


o=va.gov
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The following message will be displayed next. Click OK.
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Click OK again.
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Select the Exit and Log off option and close Outlook.
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Sending Encrypted e-mail using VA LDAP server

Open a New mail message by clicking on the New button.
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Click on the To button and the following screen will be displayed.

From the right hand side under the Global Address List, 

select LDAP – vaww.certs.va.gov
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Next, click on the Find button.
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The following screen will be displayed.  Enter the recipients name and click OK.
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If the search is successful, the name will be displayed on the left hand side column.
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Click on the To or Cc or Bcc to add the recipients.
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Click OK.

Select the Encryption button on the new e-mail and send it after typing your e-mail.
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6
Secure Web Connections and Authentication

One of the goals of the VA PKI program is to use your Digital ID as an authentication mechanism to many legacy applications.  Once you register with the enterprise PKI, your certificate can be used to grant you access to some of the VA’s backend applications.  Your Digital ID will replace the user ID and cleartext password pair used by these legacy applications.

6.1
Server Authentication

When a user visits a secure Web site, the browser and the Web server begin an SSL handshake.  During the handshake, the server certificate is downloaded into the browser.  The browser will authenticate the server’s certificate by the issuer’s signature.  Browsers contain a list of issuer’s signatures that an organization or individual may or may not trust.  If an organization or individual trust that issuer signature, then all server certificates signed by that issuer certificate will be trusted.  The browser validates the Web server’s certificate and if valid, the Web server has been authenticated. 

6.2
Client Authentication

If a Web server is configured to request client authentication (the browser), then an additional step in the SSL handshake happens.  The client passes its certificate to the Web server for authentication.  If the client certificate has the ability to generate a digital signature, then the client (browser) will digitally sign a message for the Web server to authenticate.  The Web server will validate the signature by using the passed client (browser) certificate. Recall that the private key is used to generate a digital signature and that its certificate (public-key) is used to validate the digital signature.  Thus, if the Web server can validate the signature, then the Web server has validated that the client possesses the corresponding private key and the client has been authenticated.

6.3
Internet Explorer SSL Configurations

Select the Internet Explorer icon on your workstation’s desktop.  Once Internet Explorer is active, select the View menu from the toolbar.  From the View menu, select the Internet Options.  The following screen will appear:
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Select the Advanced tab to view your web browser security features. 
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Scroll down to the Security section.  You should consult your local network administrator for the settings used by your site.  The highlighted feature, Warn if changing between secure and not secure mode, creates a pop-up screen when entering and leaving secure web pages.  If you would like to be warned when entering a secure site, then check the box by clicking in it.  The pop-up screen that is displayed when entering a secure web site is shown below: 
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Shown above is a secure web page as indicated by the yellow lock symbol at the bottom of the web page border.  This yellow lock symbol indicates that you are using the Secure Socket Layer (SSL) protocol to protect the session between your workstation and the web server.  When the yellow lock symbol is not present, then the session between your workstation and the web server is not protected.

6.4
Using your Digital ID to Access a Secure Web Server

Your Digital ID can be used as an authentication mechanism for a secure web server. On entry to such a site, a Client Authentication pop-up screen will appear. This pop-up screen is shown below.  This screen will list the Digital IDs belonging to you.  You may have more than one Digital ID permitting access to a variety of secure web sites.  However, you will have only one VA Digital ID that uniquely identifies you and that can be used to authenticate with the VA. 
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Select the appropriate Digital ID to gain authorized access.  For example, select your VA Digital ID to gain access to a VA secure web server.  After selecting the Digital ID, press the OK button.  If your Digital ID is valid, then you will be permitted access to the web site.  If you are having problems with a VA secure web server, please contact the VA PKI help line. 

IV
References

· VA end user services: https://onsite.verisign.com/DepartmentofVeteransAffairs/index.html
· User sign up form:  https://onsite.verisign.com/DepartmentofVeteransAffairs/userEnroll.htm
· Look up someone’s digital certificate:

https://digitalid.verisign.com/services/client/index.htm
· How to set up Microsoft Outlook 98:

http://www.verisign.com/client/guide/outlook98.htm
· VeriSign’s General User’s Manual:

http://www.verisign.com/client/guide
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