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Application Coordinator

 Introduction — Application Coordinator

These training examples represent common tasks performed by NOIS users that report problems and questions on software and hardware. For NOIS on Forum, this includes IRM services, Application Coordinators, and users at sites. For NOIS installed at a local site, this would include any users that have access to NOIS.

As a NOIS user you can review any information in the database. You are not restricted to only calls from your site or calls for any particular package. You cannot edit the calls or change the status of the call other than to make notes on the calls. If you need help with NOIS, contact the National Help Desk. You may call the help desk and they will log a call for you or you can enter it yourself. Please call the help desk on any emergency problem.

The examples here all relate to using the GUI. The only things you can't do with the GUI are User Defaults, Define a List, and File Setup.

Benefits

You benefit from NOIS because your problem is tracked and accounted for. You can also review previous problems to search for potential solutions. NOIS allows you to communicate by leaving notes on calls when it is more convenient. It provides additional information related to the request such as information on software, patches, installations, and contacts. It allows you to have your problem addressed by the most appropriate and available individual. Hopefully it provides you with better service.

Common Lists

Look at the File menu, Most Recently Used menu; these are the last lists that you've used. If you haven't used the lists below, look them up. Use File menu, Select List to get the Select NOIS List form. Make sure Common is selected, and choose a list. You may have to enter a Specific entry. Experiment restricting your list entries. Notice how your Most Recently Used menu changes.

Lists by Package:
These list are useful for looking at all calls for a package or all calls developed at an office (CIOFO).
Module/#:< module/version#>
Module/#, Open:< module/version#>
Package: <package>
Package, Open: <package>
	
Calls for your site:
These lists are for referred calls for a package or module/version#.
Site: <location>			all calls from this site
Site, Not Closed: <location>		all unresolved calls from this site

Calls submitted by users:
These lists are useful on calls where a referral specialist is assigned the call. You need to enter a specialist (usually yourself).
Site Contact, Not Closed: < person >
Site Contact: : < person >
Entry Person, Not Closed: < person >
Entry Person: : < person >

Other lists:
MRA: <person>			last alerts processed
MRE: <person>			last edited calls


Editing Calls

1. Log a New Call
Use File menu, Log a New Call to bring up the New Call form. Fill out the entries on the form. Make sure your phone number is correct. Click the Save button. The new call is now displayed. Now look at the File menu, Most Recent Edited menu to see that this is the last call you edited.

2. Edit a Call
Select the call you want to edit. Use Edit menu, Edit Call to bring up the Edit Call form. Note: If you are the contact on the call and the call is closed you can use this action to reopen the call. Click on the notes tab. You can copy text by using your right mouse button, or simply drag and drop the text. Spell check the new entry (use the right mouse button). Save the call.

3. Make a Note
Select the call you want to edit. Use Edit menu, Make a Note to bring up the Make a Note form. Enter some text. Paste in a common response (use your right mouse button). Note: if you don't have any common responses defined — cancel the Make a Note form and use the Options menu, Define Responses to add a common response — then make a new note and paste your response.


Reviewing Calls

1. Select a list of calls (restrict it to 5 entries)
Use File menu, Select List. Select a list. Under Restrictions, select Last # of calls and enter 5. Click OK

2. Display a Table format on all calls using a selected format
Use Format menu, Change Format. Under View, select All calls in list. Under Styles, select Table. Under Format, select Public and choose a format from the drop-down list. Click OK.

3. Display a Statistics format on all calls for Module and Location.
Use Format menu, Change Format. Under View, select All calls in list. Under Styles, select Statistics. Select fields (as described in #4). Click OK.

4. Display the same Statistics format and collate by Module
Use same instructions as #6, except also select Module/Version from the Collate by drop-down list.

5. Change back to a standard format
Use Format menu, Standard Format. The display goes back to a detailed format on a single call.

6. Sort calls on the list by site by clicking the list header
Click a title on the current list. The list is sorted by that category. Click it again. The list is sorted in reverse order. Click the first, untitled section — this is sorted by date received (the default).

7. Check the Other Information on the call
Select the call on the list. Use View menu, Other Information menu and make various selections. The information appears in a lower pane on the display. You can size the display by dragging the horizontal border. Notice how the Print menu (under the File menu) changes with the selections.

8. Look at the Graph format
Select a list with multiple calls on it. Use Format menu, Graph to bring up the graph display. Change the fields, change the style, change the options. Experiment. If you are on a bar chart, you can zoom the display by dragging from left to right to generate the window you want enlarged. To unzoom the graph, drag from right to left and upward, or make a new selection of field or style. When you are done looking at graphs, Use Format menu, Graph to toggle off the display. You can also select a call on the list; the display will return to a standard format.


Finding Calls

1. Look up a call
Use File menu, Select Call to bring up the Select NOIS Call form. If you know the last 5 numbers of the call (example: 50001), enter those and click the Submit button. You can then select the call from those found. If you know the entire call ID (example: SLC-0798-52604), enter it and click Submit. If you know the location abbreviation and approximate date the call was opened, enter the abbreviation - month and year (example: TUA-0798), then select from the list. Click OK for the selection.

2. Add this call to your Temp list
Use File menu, Save List As to bring up the Save NOIS Calls to a Storage List form. Note: if you don't have a personal storage list you will be prompted to create one. If you have multiple storage lists you can select them from the drop-down list. Select Add calls to list and click OK. Look at your Most Recently Used lists under the File menu.

3. Find text in the display
Select a call. Select the display (the cursor must be in the text). Use Edit menu, Find to bring up the Find form. Type in the text you want to find (example: undefined). Click the Find Next button. To find more occurrences use the F3 button.

4. Find text using Text Finder
Use Tools menu, Text Finder to bring up the Text Finder form. Select Last number of calls and enter 500. Enter the text you want to find in the calls (example: undefined) Click OK. Examine some of the calls to make sure they contain the text.

5. Use queries to find calls. Save the list
Use File menu, Clear List to start fresh. Use Tools menu, Query to bring up the Query form. Enter in the Field box: Module and <enter>. Enter in the Module/Version box: TIU and <enter>. Click the And selection. Enter in the Field box: Location <enter> and in the Location box: West Palm Beach <enter>. Click OK. Use File menu, Save List As to save this list (use Replace this list with these calls) and click OK

6. Use graphs to find the selections
Use Format menu, Graph to turn on the graph display. Select Status from the Fields list. Select a Pie style. With your cursor over the closed calls, do a right click. Select the menu item: Select where Status = Closed. Notice your list has changed to only the closed calls. Refresh the list by selecting Refresh List from the File menu (or use F5). Select a call in the list to turn off the graph display.

7. 
Sort the list and use selected calls to find calls
Click Status on the list header. Use Tools menu, Select from List and select the Selected Calls tab. Highlight (drag over) the closed calls. Click OK. You now have the closed calls. Refresh the list (F5).

8. Use a query to select calls
Use Tools menu, Select from List and select the Query tab. Type in Status <enter> in the Field box. Type in Closed <enter> in the Status box. Click OK. Same results. Refresh the list (F5).

9. Select calls using the list of STATUS: CLOSED. Refresh the list
Use Tools menu, Select from List and select the Lists tab. Type in Status <enter> in the List box. Type in Closed <enter> in the Status box. Click the Include List button (or <enter>). Click OK. Same results. Refresh the list (F5).

10. Use graphs and select multiple Specialists
Use Format menu, Graph to turn on the graph display. Select Specialist form the Fields list. Select a Pie style. With your cursor over a section of the pie, do a right click. Select the menu item: Add to multiples where Specialist = <somebody>. Click over another section, adding other specialists to your selections. You can review your selections using the View Multiples action. Now use Select Multiple Specialist. Your list is now only those selections.

11. Find the calls on this list that you have automatic notification on
Use Tools menu, Notifications to bring up the Notifications form. Select the Find tab. Select Only calls in the current list. Click OK. Refresh the list (F5) and repeat this except select a different user (example: Enter a specialist on a call that is in the list).


Other Stuff

1. Alert someone
Use Tools menu, Notifications to bring up the Notifications form. Select the Notify tab. Select Alert. Select any calls you want to send with the alert. Select users you want the alert to go to by selecting them from the Users box. You must click on the user so that they appear in the Send to list. Include yourself to see how alerts work (and to do #3). Note: You can remove a user from this list by double clicking. Type in the Subject of notification. Click OK.

2. Process an alert
When you have new alerts the Process Alerts button on the tool bar turns red. Note: The icon for NOIS also turns red, so even if your application is minimized, you can see the change on your taskbar (also if you'd like a sound to play, see Icons and Sounds in the online help). To process alerts, click the Process Alerts button or use Tools menu, Process Alerts. The subject of the call will be appended with who sent the alert.

3. Remove alerts
If you receive alerts on calls you don't want to be alerted on, use Tools menu, Notifications to bring up the Notifications form. Select the Remove tab. Select the calls you don't want to be alerted on. Click OK. You can do this by using View menu, Other Information and selecting Notifications. Note: If you are using Notification by Affiliation or Active-Update lists to define your notification, you will still be notified on calls meeting those criteria.

4. Patch Tracking
Use Tools menu, Profile Information to bring up the Profile Information form. Click on the Patch tab. Select a patch and click on the various reports. Click on the Location tab. Select a location. Click on the reports that have to do with patches. Click on the Module tab. Select a module. Click on the reports related to patches.

5. Package Tracking
Same as #7 except only look at Location and Module tabs. Look for reports related to package installs.

6. Browse Web Links
Use View menu, Other Information and choose Web Links to display the web links on the current call. Select from the drop-down list categories that are specific to this call.

7. Define Affiliations
Use Options menu, Define Affiliations to display packages you are affiliated with. Caution: only sign up for packages you want automatic alerts on.


Tips

Use your most recent edited and most recent alerted menus (on the File menu) to quickly find the calls you last worked with.

Quiz

1) What list would you use?
a) You processed your alerts but didn't get a chance to review them.
b) You want to look for some calls your coworker edited.
c) You need the calls for a package.

2) For the current call, where do you find out?
a) who last edited it and what was changed
b) who is automatically being alerted on this call.

3) How do you enter an urgent call?

4) How do you get your phone number to default to the correct number?

5) How would you find out if your site has all the patches for a package installed?

6) How would you find other sites that have installed a test patch you are about to put in?

7) How would you find if other sites are experience the same hardware or software problem you are seeing?

Answers
1a. MRA: <yourself>, 1b. MRE: <your coworker>, 1c. Package: <package>
2a. Status History/Audits, 2b. Notifications/List (these are buttons on the display toolbar)
3. You can't enter a call with a priority of urgent. You need to call the National Help Desk. They will page someone to assist you. They can also change the status of a call you have logged to an Urgent status.
4. Use TBOX on Forum to edit your user characteristics and edit your Office Phone.
5. Use Profile Information, select the Location tab, enter your site, enter the report Patches Not Installed (for module), and enter the module.
6. Use Profile Information, select the Patch tab, enter the patch, enter the report Locations Installed for Text
7. Select the list Package: <enter the package for this problem>, from this list use Text Finder to search for similar calls with a common word or phrase describing the problem.

Department of Veterans Affairs — VistA — August 1998
Department of Veterans Affairs — VistA — August 1998
image4.png
istA NOIS in use by Bob Andrews (FORUM) [-[o[x]
Fie Edt View Fomat Tools

Dptons_ Help

<

DEED 8 NnEEE=4ED
R AN HBRE

V1069512409 et ottt Traing 0D

1 wri-069s-12403 Request for Interactive Training CD ﬁ‘

Lonation: WED YORE, 1Y scacus (het)s
e WebLink: age =] % hitp:/himto. med va gov:80/education/cio_nteodvistau htm
C10 National Training & Education
iz VistA U

...avirtual campus dedicated to building
TSTA oo conseies

UNIVERSITY Changes in VELA healthcare, technical infrasts
—————"——" methodologies have driven the need to provic
computer applications using the latest network and interactive multi-mec

To the futre Urerd Theisarcits will ffor addfional conrsswars ,Ma_,,'_l
y

[Detaled 30282,





image1.png
Eterirformaion tofind simlar NOIS calls
The st of cals selected wil have the a test enly in at last ane of the feds.

P
© seachion el o

Search felds: Enter mulipl tewt enties on a separate .

I Subject
7 Keywords [suwseripe
¥ Petch

¥ Desciption

¥ Resolion

I Notes

¥ Personal Note

¥ Peisonal Shart Test

¥ Peisonal Long Test

o Carce





image2.png
You can select packages that you wil be alerted autmaticaly when cals are edied
‘Add of temave any packages you wil affate with thet you wish ta be dlerted on.

P
Fochi hio_ | iitdpoctaps
P T = Fiemn
Pham-Outpt | Kemel

e [
Pt Lk
[N

et

o L
e ot:

[
Gainegsiontiosse =
o it v

i Fepang
ooy et ]

Remove Al

o Cance





image3.png
Profile Information [Z1x]
Locaion| Modie. Palch | Cotac| Specit|

Patch Repot
[U-i-1a [Locations Installed for Test ]
[pusaary, e Jul 20, 1998 B
[sLevouarous, ul 10] 1998
[ausxamnsa, La ul 22] 1998
[autoons, v ul 10] 1998
Jaams azeom, Mo ul 10] 1998
[asreviLie, ne ul 23] 1998
larLana, ca ul 20] 1998
lmats, v ul 10] 1998
[pattie cresx, Mr ul 30, 1998
leay pins, £i ul 05] 1998
[prckLEY, WY ul 1s] 1998
[sEprorD ] ul 10] 1998
lp1e serine, T ul 23] 1998
lpTrInGaan, a1 Jul 14] 1998
JBLack HILLE Hos Jul 14] 1998
lso1sE, 1 ul 13] 1998
[srome, v ul 10] 1998
[srooki, wr (o) Jul 14] 1998
[puTLER, P ul 14] 1998
canraal Towa mes ul 16 1998
cantraL TExAS HCs ul 22] 1998
crarEsTON, SC Jul 12] 1998
camvmms, ul 1s] 1998
concnmatz, on ul 13] 1998
cLarksEURG, W ul 28] 1998
coLmeza, 1o ul 14] 1998
coLomeus onorc) Jul 14] 1998

Cance





