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NOIS v1.1 
 
NOIS version 1.1 has several new and useful features. While NOIS 1.0 provided a GUI 
functionality to the existing List Manager style, version 1.1 adds features to the GUI that 
go beyond the capabilities of that character based version. Please try out the new features 
by installing version 1.1 to access the NOIS database on Forum. 
 
To run NOIS v1.1 you will need to be a user on Forum. You will need a PC running 
Windows 95, 98 or NT with the ability to have a network connection to Forum. If you 
can telnet to Forum from your PC, you can use NOIS. 
 

Download and Install 
 
Use FTP to download NOIS1_1.ZIP from the anonymous software directory 
(152.129.1.110) to a temp directory on your computer. Double click the setup.exe 
program and take the defaults. It will install NOIS in the \ \ program files\vista\nois1.1 
directory. From the nois1.1 directory, drag nois.exe to your desktop - creating a shortcut. 
 
If you have been using v1.0 previously, double click the shortcut to run NOIS. 
 
If you haven't installed NOIS previously, you will need to make sure your host file is set 
up properly (see the readme.txt file). 
The host file needs the entry:  152.128.1.25   forumserver 
 
When you sign on to NOIS, take a few minutes and take a tour from the Help menu 
(Select Contents then Tour). Begin using NOIS by selecting a list under the File menu. 
 
Notes: 
 
NOIS v1.1 software needs to be installed from a setup program. You cannot simply copy the nois.exe file 
to your machine. The setup program is required to register controls on your computer (specifically, a spell 
checker and HTML ActiveX control). 
 
Version 1.0 of the client is still ok to run on Forum but it does not have any of these new features available. 
 

Local NOIS 
 
If you are using NOIS at your local facility (Local NOIS — a.k.a. LOIS), you will need 
to install the KIDS build in order to use NOIS1.1 locally. Running this client version 1.1 
to a server using version 1.0 will cause errors. You can have a shortcut running your old 
v1.0 locally and a different shortcut running the new v1.1 to Forum. 
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Web Links 
 
Web pages are just a click away. The Web Link button on the display tool bar (also on 
the View/Other Information menu) will bring up a built-in browser. There is a combo box 
to select a web page that is specific to the NOIS call being displayed. This allows you to 
easily access information about the location, package, contacts, as well as possible 
solutions to the call. 
 

 
Web inks include: Default, Personal, Functional Area, Office, VISN, Location Type, 
System, Location, Contact, Specialist, Referral Specialist, Package, Subcomponent, 
Module, Solution Index, Package Solutions, and Call. The entries correspond to URLs 
that are stored in NOIS files. NOIS Coordinators can update these entries. Users can 
update their user defaults with a personal page. 
 
The most specific information for the call is displayed by default. These categories 
provide a starting point for browsing the specific information you are looking for. 
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Browsing and Attaching Web Links to Calls 
 
A web link can be directly attached to the call (NOIS Specialists can use the pin button 
next to the combo box). In this way it is possible browse for FAQs, policy, solutions, 
documentation, etc. If the page is specific to the NOIS call, it can be attached. You can 
also batch edit a web link to multiple calls. 
 

 
Attaching web links to calls is audited, but they do not update an edit (that is they do not 
trigger an alert). They can be applied to closed calls without reopening the call. The web 
link field is also searchable, displayable and printable.  
 
Use the right mouse button to copy a web link so that you can paste it to another web 
browser or the batch editor. The right mouse button can also launch your default browser 
(Internet Explorer, Netscape, etc.) to this address.  
 
The web link URL is displayed on the detailed format for the call. From any word 
processing display, you can use the right mouse button to launch your browser to a web 
address. The cursor must be on a line that contains a URL. 
 
Note: 
The HTML control is somewhat limited: no text copying, no downloads, no pages with frames, etc. You 
may only want to use it to navigate to a page and then launch your browser. 
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Creating and Editing Web Pages 
 
From the Tools menu, a Specialist can use the Create Web Page to create a solution to a 
common problem and have that information stored as a web page in the solution 
database. The entry consists of a package, title, problem, and solution.  
 
Saving the entry creates a web page (stored on a web server). Links are also made to a 
package solutions page and the main solution page. You can also link the page to the 
current call. 
 

 
 
The information in the web page is also stored in a NOIS file. Pages can be edited using 
Edit Web Page from the Tools menu. The pages can be looked up (either by browsing to 
the solution page beforehand, or by selecting the package and solution). 
 
The page shows the person who first created the page and the last user updating it. 
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Solution Database 
 
The Solution Index page shows packages that have solutions. You can click a package to 
go to the Package Solution page. This page lists the solutions for that package. You can 
click the title of a solution to go to the description of the problem and solution. You can 
go backwards by clicking the link to go back the Package Solutions or Solution Index 
page. 
 

 
You don't need NOIS to access these solutions. Use your desktop browser to go to the 
Solution Index URL. Specialists do need to use NOIS to edit these pages, since the 
information is controlled by what is stored in the NOIS WEB file. 
 
Updates such as formatting and new features can be controlled at the server. 
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Graphs 
 
Graphs provide an easy way to look at simple statistics from NOIS calls in a list. Output 
from statistics is also put into a table so that data can be easily exported to a spreadsheet 
(previously you would need to export to a spreadsheet and use a pivot table to categorize 
calls for graphing). The Graph button on the display tool bar or an action on the Format 
tool bar will toggle on and off the graph display. You can select different fields, styles, 
and options to graph. 
 

 
 
You can use graphs to "drill down" on information or as a means to do simple queries. By 
using the right mouse button and clicking on a section of the graph, you can "Select" only 
those calls for that section. Then change to another field to view. Use the "Remove" 
condition to remove calls from the list. To select or remove multiple items use the "Add 
to Multiples" on the right mouse click menu. You can then select multiple entries from 
the graph. You can also change lists, use queries, duplicate features or Text Finder to 
update the graph.  
 
This is actually fun! 
 
Notes: 
Some fields are not very suitable for graphing.  
Graphs can be printed (some outputs may not look too good). 
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Spell Check 
 
Spell checking can be done on any memo field that is not read-only. You will find this as 
an action when using the right mouse button. You can spell check a single word (double 
clicking in a memo highlights a word, triple click selects the line), a selection, or the 
entire text. Text in all capital letters and text with numbers included in the word are 
skipped — good for skipping variable listings and error trap information. 
 

 
Note:  
When spell checking a selection, the edits are made after spell checking is done. When spell checking the 
entire text, the changes are made as you make them. No custom dictionary is available. 
 

Make a Note 
 
This may seem like a small feature, but it's actually very handy for when you only want 
to make a note on a call. This is very common for non-specialists who do not edit other 
portions of the call. Make a Note is found in the Edit menu or as a button on the Display 
Tool bar. 
 

 
This form is displayed much faster than using the Edit Call action. This action is not 
enabled if the call is closed or canceled. If you need to edit other items (workload, status 
changes, etc.), use Edit Call. 
 



8  NOIS v1.1 — New Features 

Department of Veterans Affairs — VistA — August 1998 
 

List Organizer 
 
The List Organizer lets you easily use storage-only lists. These lists are used like mail 
baskets to save calls. Calls are only added or removed from these lists when you 
specifically change them. The List Organizer is found on the Tools menu. Use the right 
mouse button to easily create and delete these types of lists (Previously you had to use 
Define a List to create and delete these personal lists and Save List to add or replace the 
calls). Any user can create, rename, and delete their own lists. 
 

 
By convention these lists use the name TEMP-LASTNAME and then some other 
identification. This avoids confusion when looking up lists. Temp lists are available when 
you save calls to a list. 
 
You can use multiple temp lists to organize calls into specific areas that you are working 
on. Simply drag and drop calls from the current list to your lists. 
 
The top portion of the List Organizers has some choices for filtering the calls you are 
looking at. These may be helpful when dividing up calls onto different lists (ex. You 
receive an alert and save the calls to your lists). 
 
Note:  
The list name cannot be used in a table output (since only fields for the call can be displayed). You can still 
use lists to organize your calls and then use the batch editor on the list of calls to edit fields and assign 
personal fields that can be used with a spreadsheet. 
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Personal Fields 
 
Personal fields are four fields (short text, long text, number, and note) that are used to 
categorize a NOIS call. Only you can view and search for your entries. These are not 
sharable. They are useful for tagging calls so that you can produce spreadsheets grouped 
into your own categories or to maintain private notes. You can edit these from the using 
Edit Call, Edit Personal Fields, or the Batch Editor actions on the Edit menu. 
 

 
When you search personal fields, you are only searching your own entries. The fields are 
not audited. Edits do not trigger an alert. You can edit closed calls without reopening. 
The fields can be used in searches (queries & Text Finder) and displays. 
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Batch Editor 
 
The batch editor can be accessed from the Edit menu. You can make changes to fields, 
status,  personal fields, and workload to any calls in the current list. You can also batch 
delete most entries. Closed calls can be skipped or reopened. 
 

 
When you have made changes and pressed the Save button, you will be asked which calls 
to apply those changes to in the list. You can review those changes before applying the 
changes. Batch editing is restricted to NOIS Specialists. 
 

 
Note:  
There are restrictions as to the number of calls that can be edited at once. Personal fields, workload, and 
web links edits are made without reopening calls. Dates for workload or closing a call may vary depending 
on when the call was opened. 
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Duplicates 
 
A duplicate NOIS call is a call that is the same request (problem or question) of a 
previously made call. A call that is from the same requestor on the same request is 
usually just canceled. A duplicate is usually from a different requesting location (ex. a 
package install crashes with the same problem at multiple sites). It is not canceled. It is 
tracked and resolved for that site. 
 

 
Use the "Change using Duplicates" submenu to show or hide duplicates. Use "Expand 
List" to add any calls associated with the current list (ex. To close all calls that have been 
fixed for this problem). "Collapse List" replaces the list with only the primary calls (ex. 
Work with  only unique problems). "Expand Call" adds any duplicates of the currently 
selected call (you get an alert and want to see other similar calls). "Duplicates of Call" 
removes all calls from the list except those associated with the selected call (you only 
want all calls associated with this problem). 
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Associate Calls 
 
A Specialist can associate a call with another call so that the calls are grouped together. 
Associating calls is done using the Associate Call or Duplicate Editor actions on the Edit 
menu. Use Associate Call if you know the specific call you wish to assign the call to. Use 
Duplicate Editor to drag and drop calls onto each other to compose duplicates. Each call 
is always associated with a primary call. This call can be itself or another call. Editing 
these associations does not trigger an alert (audits are separate from the call's audit 
history (use the button on the Duplicate Editor or right mouse button to view the history 
of changes. 

 
The primary call can be edited with the "Edit Primary Call" action on the Edit menu. If 
you are only dealing with a problem — not all reports of that problem — the primary call 
becomes a common place to follow progress. 
 

 
Three fields (primary call, duplicate to, and duplicate history) can be used in searches and 
displays. The primary call is displayed on the detailed format. If the call has a different 
primary call than itself, it can be viewed using the Primary Call button, or from the 
View/Other Information menu.  
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Duplicate Editor 
 
The easiest way to see the relationship between duplicates is to use the Duplicate Editor 
under the Edit menu. You can use the buttons on the right side of the form or the right 
mouse button to make changes in associating calls. 
 

 
Drag and drop a call onto another call to make changes. The call being dragged will 
associate to the call it is dropped on. Changes are only made when saved. Experiment to 
see how calls are affected by changes. Ex. which call becomes the primary call, how 
subordinate calls are changed, etc. 
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Other Stuff 

What's This? Help on Main Form 
Select What's This? on main form to get context sensitive help similar to using the 
question mark button in the upper right corner of secondary forms. 

New Help 
Online help has been updated 

List Selection by Category 
Filter for common and owned lists. 

Personal Fields on Text Finder 
Personal short text, long text, and note are searchable with Text Finder. 

Select Account 
Parameter to start up shortcut and select the account to sign into. (include ASK in the 
shortcut parameter) 
 
 

Bugs fixed 
lots of stuff 
 

Things not fixed 
lots of stuff 
 


	Building Links between Problems and Solutions
	NOIS v1.1
	Download and Install
	Local NOIS
	Web Links
	Browsing and Attaching Web Links to Calls
	Creating and Editing Web Pages
	Solution Database
	Graphs
	Spell Check
	Make a Note
	List Organizer
	Personal Fields
	Batch Editor
	Duplicates
	Associate Calls
	Duplicate Editor
	Other Stuff
	What's This? Help on Main Form
	New Help
	List Selection by Category
	Personal Fields on Text Finder
	Select Account

	Bugs fixed
	Things not fixed

